GlobalProtect Connection Issues

Incident Report for McLeod Hosted

Resolved

This incident has been resolved. We will continue to monitor.
Posted Jun 03, 2026 - 14:51 CDT

Update

Some users are experiencing intermittent connectivity with GlobalProtect. We are continuing to investigate the issue.
Posted Jun 03, 2026 - 10:02 CDT

Investigating

Some users are experiencing intermittent connectivity with GlobalProtect. We are aware of and investigating the issue.
Posted Jun 03, 2026 - 09:31 CDT
This incident affected: Global Protect VPN Client (DFW Global Protect VPN Login, IAD Global Protect VPN Login).